LFS5.0 Chapter 6 GCC pg 123/289 -- LONG

Daniel Ignat daniel.ignat at splinux.com
Thu May 6 04:05:33 PDT 2004


I'm not sure if this is the best solution, but I tell you what worked
for me: I had problems too compiling with the patches. 
Try it again without them. For me it worked well so. It also seems
to me that the patches' 'problem' is covered later (so that you may
not leave the system in a weird build situation) when it says 
about include problems.. anyway, try compiling gcc without
the patches, for me it was the solution.

On Thu, 2004-05-06 at 12:35, Mark Carey wrote:
> Hi, 
>  
> I am now stuck trying to build GCC in Chapter 6.  I apply the two patches 
> specified and building gcc after issuing the ``make'' command causes variable 
> behaviour.   
>  
> Build Host: 
> Knoppix V3.2 
> AMD Athlon XP 2000+ 
> 256MB RAM 
> 512MB swap partition 
>  
> As the build host is Knoppix I have had to chmod 666 /dev/ptmx inorder to get 
> pty support working.  I have tried building from runlevels 1, 3, fluxbox and 
> kde with varying levels of completion 
>  
> Here are 4 snippets of failures from different runlevels.  Messages captured 
> using make > ../gcc-build-errors-1 so the error causing failure is not 
> captured.  Error can be a seg fault in cc1plus sometimes no direct failure 
> results and make reports error and exits. 
>  
> 1. 
> ----- 
> /sources/gcc-build/gcc/xgcc -shared-libgcc -B/sources/gcc-build/gcc/ 
> -nostdinc++ -L/sources/gcc-build/i686-pc-linux-gnu/libstdc++-v3/src 
cut




More information about the lfs-support mailing list