Building glibc-2.3.2 pass1 with static gcc hangs

Ken Moffat ken at kenmoffat.uklinux.net
Mon May 10 13:01:49 PDT 2004


On Mon, 10 May 2004, Joerg Hahn wrote:

> Moin

Hi.
>
> I try to build lfs-5.0 on a woody stable. As there is only a gcc-3.0 I
> tried to use the fresch build gcc in /tools/bin. Everything works fine

 I don't follow you.  The first things we build are binutils and gcc,
after that we're using a gcc we've built (look where /tools/bin is on
your PATH).  As an aside, when did gcc-3.0 get into woody ?  My version
of Woody had 2.95.4.

> until it comes to the test in iconvdata/run-iconv-test.sh. I found out,
> that this script hangs at the line 44 in which the script looks for the
> type of echo used. It goes like this:
> if (echo "testing\c"; echo 1,2,3) | grep c >/dev/null; then
>   ac_n=-n ac_c= ac_t=
> else
>   ac_n= ac_c='\c' ac_t=
> fi
> I don't think that I stopped the script to soon, as it went about 15
> minutes. Is there something I've forgotten to do or read?
>
>

 There isn't exactly a lot to go wrong in those lines, is there ?  The
only things that come to mind are that either echo or /dev/null are
behaving oddly.  In any sane package, this sort of test would be done
during `configure', but from what you say it sounds as if this is during
the build.

 First try

 (echo "testing\c"; echo 1,2,3) | grep c >/dev/null; echo $?

If that displays 0 as expected then the problem might be somewhere
else.  If that doesn't display 0 then maybe you're using an unexpected
shell, or else echo or /dev/null (c 1,3) or even grep are defective.

 Have you tried doing this before, and are now trying again without
wiping out both the source and build directories ?

Ken
-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the lfs-support mailing list