chroot problems...

Roel Neefs geryon at gaosu.rave.org
Mon May 10 19:50:45 PDT 2004


On Tuesday 11 May 2004 04:34, Felix Jodoin wrote:
> Hi,
> I have been having an error at the end of chapter five (or beginning
> of chapter 6) in LFS 5.0. I have seen similar occurrences on this
> list, but none that relate to the problem I am having. I get the
> error (after chrooting and checking that "echo $LFS" gives me
> /mnt/lfs):
> /tools/bin/env: command not found.
> I run /tools/bin/env, and it's there. I tried "chroot $LFS" (alone)
> and I got:
> /bin/sh: command not found.

It's exactly the same problem as the others so also the same solution ;)
When you try to work around it by only using chroot $LFS, it will try to 
use the default /bin/sh, which isn't there yet. 
And running /tools/bin/env by itself also works cause then it's still 
ch5 and it sees the libs in your host, when chrooting those libs aren't 
accessible.

http://www.linuxfromscratch.org/lfs/faq.html#any-no-such-file

It's most of the times one of these 2 issues:
1) The specfilechange wasn't done as it was supposed to.
2) Your PATH variable didn't have /tools/bin at the front while 
compiling the packages.

> Can anyone help me?
> Thanks,
> Felix Jodoin
> Email: felixj at shaw.ca

-- 
Roel Neefs
http://lfs.rave.org/lfs/news.html and ftp://gaosu.rave.org/pub/linux/lfs



More information about the lfs-support mailing list