perl compile error in chapter 5 of lfs 5.1-pre2

JP capn_shoe at yahoo.com
Sat May 15 11:49:16 PDT 2004


Ken Moffat wrote:
> On Fri, 14 May 2004, JP wrote:
> 
> 
>>When I try to compile perl in chapter 5 of lfs 5.1-pre2 i get the
>>following error:
>>
>>/mnt/lfs/tools/bin/../lib/gcc-lib/i586-pc-linux-gnu/3.3.3/../../../../i586-pc-linux-gnu/bin/ld:
>>cannot find -lgdbm
>>collect2: ld returned 1 exit status 
>>I can't compile the test program.
>>You have a BIG problem.  Shall I abort Configure [y]
>>Ok.  Stopping Configure.
>>
>>It seems perl is trying to link against the libgdbm.so, which is on the
>>host system, but not the lfs system.  I have tried to compile it several
>>times, unpacking and patching the source fresh each time.
>>
> 
> 
>  Based on what I've seen, I think the problem is something different.
> 
> 
>>What's going on? Is this some mess up with the toolchain, or something
>>freaky with perl?  Oh, yeah, I am running the uname hack on a vmware
>>redhat 9 install so this will run on an old pentium classic as a router.
>>
> 
> 
>  Does that mean RH is running as a "guest" under "another" OS ?  That is
> a decidedly uncommon way to build, you might have to look at what
> alternatives are available for configuring perl.

Umm.. yes (no if you mean MS by "other os").  RH9 is running as a guest 
on Fedora Core 1.  I decided to use this setup because I didn't have any 
extra space for a LFS partition.  Since I am going to run this on an 
entirely different machine anyway, I'm just going to ghost the VM to an 
old pentium classic.
> 
> 
> OK so far, but then
> 
> 
>>Which of these apply, if any? [redhat9-virtual]
>>hint to use instead? [redhat9-virtual]
>>Operating system name? [redhat9-virtual]
>>Operating system version? [none]
> 
> 
> Quite different, mine shows (copied by hand)
> 
> Which of these apply, if any? [linux]

That was it.  I eventually ran the Configure (not configure.gnu) Script 
with the options -Dprefix=/tools -Dstatic_ext='IO Fcntl POSIX' and 
answered all the questions manually.  That's when I noticed the OS being 
  detected as "redhat9-virtual," the hostname of the VM. I changed it to 
linux and everything went fine.
> 
>  You'll see it found my (old) kernel version.  The redhat9-virtual is a
> new one to me, and a quick google didn't help.

I googled it too, and found nothing.  Has anyone else tried to compile 
LFS on VMware and had the same problem here?  Is this VMware specific, 
or something else?

Thanks,
JP





More information about the lfs-support mailing list