Building glibc-2.3.2 pass1 with static gcc hangs

Joerg Hahn hahnjoerg at arcor.de
Mon May 17 13:49:04 PDT 2004


Moin

Thanks for helping me. I ask first, and than looked for the solution.
I'm sorry.
 
>  I don't follow you.  The first things we build are binutils and gcc,
> after that we're using a gcc we've built (look where /tools/bin is on
> your PATH).  As an aside, when did gcc-3.0 get into woody ?  My version
> of Woody had 2.95.4.

gcc-3.0 isn't in the PATH normally. I installed it some times ago.

>  There isn't exactly a lot to go wrong in those lines, is there ?  The
> only things that come to mind are that either echo or /dev/null are
> behaving oddly.  In any sane package, this sort of test would be done
> during `configure', but from what you say it sounds as if this is during
> the build.

This behavior comes up in "make check" in the iconvdata directory. I
fixed it. I think it was the LC_ALL=POSIX that was missing. I did not
read anything till now, but what is so dangerous about not setting
LC_ALL? Where is the explanation for it?

>  (echo "testing\c"; echo 1,2,3) | grep c >/dev/null; echo $?

It works fine and gives a 0. I tried to add an echo, too. I found out
that a grep was very busy kicking the break of my system. The added echo
never wrote anything on the screen. As I wrote, I stopped the grep after
10 or 15 minutes. BTW LC_ALL isn't set. I don't understand the
difference between these two sutuations.

-- 
und dann

george



More information about the lfs-support mailing list