Grub stuck in reboot cycle

Michael Brown michael at chatterwaul.com
Thu May 20 07:21:39 PDT 2004


Hi again folks,

I've got my first LFS system installed but I can't boot it. I used LFS
5.0, and my only deviation was to use kernel 2.4.26 instead of 2.4.22.
There is another post here at lfs-support outlining a similar boot
problem, but my system is already set up the way he fixed his (at least as
far as I can tell:
http://archives.linuxfromscratch.org/mail-archives/lfs-support/2004-February/022272.html.

Here's what happens for me: shutdown -r now reboots, pulls up the Grub
menu with LFS 5.0 displayed in green. After 30 second countdown (or I hit
enter), the following text flashes on the screen

Booting 'LFS 5.0'
root(hd1,2)
 Filesystem type is ext2fs, partition type is 0x83
kernel /boot/lfskernel root=/dev/hdb3 ro

and then the system instantly reboots. Left on its own, this cycle would
likely continue forever.

Here's my setup:

Fedora Core 1 (host):
hda1	/boot
hda2	/
hda3	swap

LFS:
hdb1 	empty (long story)
hdb2	swap
hdb3	/

My menu.lst reads as follows:
--------------------------
default 0
timeout 30
color green/black light-green/black
root (hd1,2)
kernel /boot/lfskernel root=/dev/hdb3 ro
--------------------------

My fstab reads:
--------------------------
# filesystem  mnt-point   fs-type   options        dump  fsck-order
/dev/hdb3     /           ext2      defaults       1     1
/dev/hdb2     swap        swap      pri=1          0     0
proc          /proc       proc      defaults       0     0
devpts        /dev/pts    devpts    gid=1,mode=620 0     0
shm           /dev/shm    tmpfs     defaults       0     0
--------------------------

hdb3 is toggled to be bootable, by the way. Here's the output from fdisk
/dev/hdb, p:

   Device Boot  Start   End    Blocks   Id  System
/dev/hdb2          26    88    254016   82  Linux swap
/dev/hdb3 *        89   619   2140992+  83  Linux

When I open Grub shell (in chroot /mnt/lfs), I type:
--------------------------
> root (hd1,2)
> setup (hd0)
> quit
--------------------------

(Should I NOT be in chroot when I run grub shell? Or does it matter?)

The output of "setup (hd0)" contains:
--------------------------
Running "install /boot/grub/stage 1 d (hd0) (hd0)1+15 p
(hd1,2)/boot/grub/stage2 /boot/grub/menu.lst" ... succeeded
--------------------------

I originally only copied stage1, stage2 and e2fs_stage1_5 from
/usr/share/grub/i386-pc/ into /boot/grub but after a few rounds of this I
decided to copy over all files from /usr/share/grub/i386-pc/. It didn't
help.

Any ideas where to begin to fix this? Would you like to see kernel.h or
any other files or outputs?

Also, I made an LFS bootdisk following the instructions in the book
(contains stage1 and stage2) and whenever I try to boot from it I get a
"Read error". And once I get rebooted into Fedora using my backup Fedora
bootdisk, I can't mount the LFS boot floppy. It's like it's corrupt. Is it
possible that the stage2 file is bad? If so, how could I check it? And
I've also tried simply copying stage1 and stage2 to a blank floppy, but
then I get "Boot failed".

Help?

PS - If the answer IS in that previous post, please accept my apologies
for asking this question. But I don't believe that post answers this
question.

Also, there's another post here about resetting defaults in BIOS. Could
that be my problem?

Humbly,
Michael Brown
[ michaelbrown ]



More information about the lfs-support mailing list