[LFS 5.1 - runit] /proc is empty (not mounted)

feanorelf at fastwebnet.it feanorelf at fastwebnet.it
Mon May 24 02:08:53 PDT 2004


Hallo!

Yesterday I had just completed the installation of my LFS 5.1 system, with
some little deviations, i.e.:
1) using the 'More control and package management using package users' (v0.8)
hint
2) using the 'Build with runit' hint

I also had just installed iptables and dhcp as per BLFS, and while searching
for my Eth cards IO addresses with
cat /proc/pci, I discovered my /proc was empty! 
Now, with more attention, I noticed the little ugly message at boot: message:
/proc is empty (not mounted ?). 
Actually, 'ls /proc' confirmed that, but 'mount' outputted the proc fs as
mounted on /proc. Maybe a concealed bug on fstab? 
I tried 'umount proc' && 'mount -a' and this time the proc was there.
After googling a little, and finding no hint, I tried tampering with mountfs:
I removed the '-f' option from 'mount -f proc'
and now proc gets mounted. The problem is I got it by trial and error (I
am a linux newbie), yet I am clueless about what 
I did and why it works, and if there is any more proper way.
Is there an explanation?

Thanks,
Luciano




More information about the lfs-support mailing list