gettext configure failed for autoconf-lib-link

Ken Moffat ken at kenmoffat.uklinux.net
Wed May 26 04:59:23 PDT 2004


On Wed, 26 May 2004, dzh wrote:

> Hello .
>
> I'm installing LFS 5.1,when i began to install the gettext ,i got the
> following result:
> The config.log is also put here.
>
> lfs at dzh:/mnt/lfs/sources/gettext-0.14.1$ ./configure --prefix=/tools
> checking for a BSD-compatible install... /tools/bin/install -c
> checking whether build environment is sane... yes
> checking for gawk... gawk
> checking whether make sets $(MAKE)... yes
> checking build system type... i686-pc-linux-gnu
> checking host system type... i686-pc-linux-gnu
> configure: creating ./config.status
> config.status: creating Makefile
> configure: configuring in autoconf-lib-link
> configure: running /bin/sh './configure' --prefix=/tools
> '--prefix=/tools' --cache-file=/dev/null --srcdir=.
> ./configure: line 1164: config.log: Permission denied

 That looks to be the best pointer to what is wrong.  What does the area
around line 1164 of the configure script do to `config.log' ?

> configure: error: /bin/sh './configure' failed for autoconf-lib-link
>
> ########config.log#########################
>
>              This file contains any messages produced by compilers while
> running configure, to aid debugging if configure makes a mistake.

 Strangely, you've got a config.log. From the error above I'd half
expect not to see one.  Who owns it (lfs, I hope), what are the
permissions, have you been running any of this as a user other than
lfs, and how full is the disk ?

Ken
-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the lfs-support mailing list