apt-get question

linux at nplinux.org linux at nplinux.org
Thu May 27 00:14:45 PDT 2004


Dear all:

i have followed the LFS 5.0 book and finished installing the temporary
system.
now before installing packages i am planning to use chekinstall, dpkg and
apt-get. i have installed dpkg successfully. but when i try to install
apt-get's 'make' got the following error like"

=---
policy.cc: In member function `void
   pkgPolicy::CreatePin(pkgVersionMatch::MatchType, std::basic_string<char,
   std::char_traits<char>, std::allocator<char> >, std::basic_string<char,
   std::char_traits<char>, std::allocator<char> >, short int)':
policy.cc:186: error: no matching function for call to `
   std::vector<pkgPolicy::Pin, std::allocator<pkgPolicy::Pin> >::insert(
   __gnu_cxx::__normal_iterator<pkgPolicy::Pin*, std::vector<pkgPolicy::Pin,
   std::allocator<pkgPolicy::Pin> > >)'
/tools/include/c++/3.3.3/bits/vector.tcc:89: error: candidates are:
   __gnu_cxx::__normal_iterator<_Tp*, std::vector<_Tp, _Alloc>

-----



i think apt-get is looking for some other packages ..
so it wud be a good help if i know what pakages needs to be installed
before installing apt-get in my clean LFS.


Thanks
Paras






More information about the lfs-support mailing list