error on chapter 6 readjusting

Ken Moffat ken at kenmoffat.uklinux.net
Thu May 27 02:51:34 PDT 2004


On Thu, 27 May 2004, Thomas Buchmann wrote:

>
> i forgot to say that libbfd-2.14.so was not in /usr/lib. it still was in
> binutils-build/bfd/.libs/ and i manually copied it to /usr/lib and ran
> ldconfig afterwards. but i still get the same error message :(
>

 In that case, something wrong happened in your binutils install, but
I've no idea what.  The libraries shown in your previous reply seem
correct, and I cannot see how they would not be there.

 Afraid I'm out of ideas on how to fix it.  If it was my build, I'd look
around my scripts and logs to try to spot what I'd missed or done
wrongly, then roll back to a backup from the end of chapter 5.  If you
don't have such a backup, rolling back to the beginning is an extreme
answer, but does not guarantee progress unless you can identify what
you did wrong.

 I've just looked at the book's instructions, the "if you deleted
binutils" suggestion doesn't really help here.  Maybe somebody else will
recognise the problem.

 Sorry.

Ken
-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the lfs-support mailing list