LFS 5.1 on Fedora Core 2 GCC Configure Errors

Kevin P. Fleming kpfleming at linuxfromscratch.org
Thu May 27 23:10:00 PDT 2004


Richard A Downing FBCS wrote:

> Fedora Core 2 is causing the problem, because it is Linux-2.6.x based 
> and LFS 5 is Linux-2.4.x based.  You'll need an older distro, or you 
> could try building LFS-unstable.

Actually, the real problem here is that the host is using a version of 
binutils newer than 2.14, and LFS 5.x builds binutils-2.14. When you 
attempt to build gcc-3.3.x, it tries to use binutils-2.15 specific 
features (--as-needed), but the binutils that was just built does not 
support them.

There is a workaround, but it's not terribly pretty. It's better to just 
not use a host that's newer than what you are trying to build. Fedora 
Core 1 will work fine for LFS 5.x, as will many other distros.



More information about the lfs-support mailing list