Problems building binutils Pass 1

Jason Brooks icedown at
Tue Sep 14 19:51:06 PDT 2004

I am attempting to build LFS via LFS-5.1.1.  I am running RedHat Fedora Core
2 on a VMWare Workstation.  (working on getting a real box).    I can build
and install binutils fine. But when I start configure for gcc I get this

*** This configuration is not supported in the following subdirectories:
     target-libstdc++-v3 target-libf2c target-libffi target-boehm-gc
target-zlib target-libjava zlib fastjar target-libobjc
    (Any other directories should still work fine.)
Created "Makefile" in /mnt/lfs/build-gcc using "mt-frag"
/tools/bin/ld: unrecognized option '--as-needed'
/tools/bin/ld: use the --help option for usage information
collect2: ld returned 1 exit status
*** The command 'gcc -o conftest -g -O2   conftest.c' failed.
*** You must set the environment variable CC to a working compiler.

When I run configure per the instruction I get this, and I also tried
setting build, host, and target systems to 
i386-unknown-linux-gnu and still get the same results.  Should I be trying
to build via the test book or am I doing something wrong that I'm not

More information about the lfs-support mailing list