unrecognized mount option boot error

CROTEAU, BRIEN LT (VAQ139) brien.croteau at cvw14.navy.mil
Mon Sep 27 16:44:55 PDT 2004

I am writing to try to get some advice in completing my LFS 5.0 project.  I
think that I have completed the entire book, and I ran all the checks when
compiling all the software.  I am encountering the following errors when
booting up my new kernel:

	EXT2-fs: Unrecognized mount option defaults (or any other option
that I try to pass in rootflags=???)
	mount:  / not mounted already or bad option
	  - or -
	Kernel Panic:  VFS:  Unable to mount root fs on 03:06
	  - depending on the options I pass to the kernel in grub 

The first error results when I run the menu.lst included below.  The second
occurs when I don't include a root= parameter.  

Some details about my system.  The host was a RedHat 9 system on the
/dev/hda5 e2fs partition.  I built all the LFS stuff on a 1.4 gb e2fs
partition mapped to /dev/hda6.  I did option to include ext2fs support into
the kernel when I configured the kernel.  I looked through the support
archive and Google and found one thread from March 2001 blfs-support mailing
list that sounded similar, but did appear to get resolved.  I am currently
deployed and have very rotten internet connectivity, so I would appreciate
any help, please suggest any other info that would help diagnose my issues.

Thanks,  Brien Croteau

# Begin /etc/fstab

# file-system  mount-point  fs-type   options    dump   fsck-order
/dev/hda6       /            ext2     defautls    1       1
/dev/hda7       swap         swap     defaults    0       0
/dev/hda5    /mnt/old-sys    ext2     defaults    1       2
/dev/hda1      /boot         ext3     defaults    1       2
proc           /proc         proc     defaults    0       0
devpts       /dev/pts       devpts gid=5,mode=620 0       0
shm          /dev/shm       tmpfs     defaults    0       0
/dev/floppy /mnt/floppy      auto  noauto,owner   0       0
/dev/cdrom  /mnt/cdrom  udf,iso9660 noauto,owner  0       0

# End /etc/fstab

# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/hda5
#          initrd /initrd-version.img
title Red Hat Linux (2.4.20-8)
	root (hd0,0)
	kernel /vmlinuz-2.4.20-8 ro root=LABEL=/
	initrd /initrd-2.4.20-8.img

title LFS 5.0 (2.4.22)
	kernel (hd0,5)/boot/lfskernel root=/dev/hda6 ro

# End menu.lst

More information about the lfs-support mailing list