bash - get no prompt back after executing a command - 100% CPU

Justin Julian d4mography at gmail.com
Wed Apr 6 07:41:16 PDT 2005


Oliver,

All I can say is that I would advise against ANY deviation from the
LFS procedure. Every time, I make any slight deviation from the
spelled out procedure, the whole thing falls apart.

Having said that, I think there is a link on the LFS website where you
can download all of the packages EXACTLY as they are specified in the
document. I would try working with that version first before debugging
any problems that occur thereafter.

<historical stuff>

I have screwed up on an LFS 6.0 install somewhere building the
Binutils package. I have decided to start over, trying to find the
problem. I also make several backups along the way, and store the
tarballs on a separate drive. That way I can always roll-back the
process a few steps if something doesn't quite look right.

For about 1 year I used an LFS 5.0 system with a subtly broken
toolchain. All of the packages compiled properly, and the system would
boot up and run quite nicely. I moved on to BLFS, and that worked
perfectly as well. However,
Upon installing what I call third party software (non LFS / BLFS
packages) I was plagued by the occasional "Error 2" when compiling,
with no discernable cause to be found, and no observable connection
between concurrent failures. When I attempted to use that LFS 5
install to build LFS 6 NOTHING WORKED. Lesson learned, follow the
instructions EXACTLY as indicated. If something doesn't work, start
again, get it right. You never know what you'll end up with in the
future.

</historical stuff>

Not really alot here, but hope what I've shared helps.

Justin Julian.

On Apr 6, 2005 10:42 AM, Oliver <ol_lfs at onebitmore.net> wrote:
> Hello.
> 
> There's a problem with the bash in my new LFS 6.0 system.
> The system is booting, I can login ... but after the execution
> of a simple command (ls, less ....) I don't get back the prompt.
> The bash then uses nearly 100 % CPU and the only thing I
> can do is "kill -9" with the bash process.
> If I use the bash binary from my host (debian 3r4 , bash2.05)
> everything is o.k.
> "ldd" said both binaries are linked against the same libraries.
> I've tried to compile bash3 and bash2 with and without build-in
> readline. With and without patches. Nothing helps.
> The only thing I changed from the standard LFS 6.0 book is the
> Glibc. I took the final version 2.3.4. Not the CVS version (20040701)
>  which comes with the other packages in the tarball.
> 
> thx all for your help
> Oliver
> --
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
>



More information about the lfs-support mailing list