PTY-Problem

Prof. MAAD murmel_7 at yahoo.de
Fri Apr 8 11:17:42 PDT 2005


Hello everyone,

I have a big problem with my LFS 6.0 Installation at the moment.
Everything went fine til Chapter 6. After I chroot'ed into the 
LFS-Environment, I tried to mount the virtual kernel filesystems(6.8),
then I continued. In Chapter 6.13, when I was asked to install Binutils, 
the problem showed up. The command "expect -c "spawn ls" said, that my 
chroot-environment has no more pty's left. I had a look into the FAQ and 
the mailing lists and did a lot of stuff that was said there, but 
nothing worked. Then I had a look into the CVS-Version of the book and 
tried the new commands for Chapter 6.8, but that didn't work as well.
Also, there's a very mysterious behavior of the chroot-environment. When 
I just chroot'ed and then switched to /dev, he shows me the "console" 
and "null" device. But when I then create the "stdin","stdout", etc.. 
links, the "console" and "null" devices are no longer there.

So my problem is: How can I get enought PTY'S to continue with the book?

Thanks,
  Prof. MAAD

P.S.: Book Version: 6.0 - German Translation
       Host System: Suse 9.2 Pro - Kernel 2.6.9 - GCC 3.3.5
       Please don't be upset about potential grammar and spelling 		 
   mistakes, I am just a german boy.
       Personal E-Mail: prof.maad at gmail.com







More information about the lfs-support mailing list