stuck at configuring binutils

cfk cfk at pacbell.net
Sat Apr 30 12:41:19 PDT 2005


On Saturday 30 April 2005 13:08, Ken Moffat wrote:
> On Sat, 30 Apr 2005, cfk wrote:
> >  When I run the configure script, on the seventh line of the script,
> > where the check for gcc functionality is performed, the script tells me
> > that "C compiler cannot create executables".
> >
> >  Running 'gcc -v' returns gcc version 3.4.2. This is a FedoraCore3 system
> > and has built executables in the past, so the message must be misleading.
>
>  Check what it says in the output from configure (config.log).  You
> should see the command line (something like gcc -o conftest conftest.c)
> together with the skeletal program.  If there is nothing else that
> looks informative, copy the program into conftest.c and run the command
> line to see what error messages you get.
>
> You don't say which version of the book you're trying to build, but in
> the past people have had problems trying to build "old" toolchains using
> fedora hosts (fedora tends to have the bleeding edge in it).
>
> Ken
> --
>  das eine Mal als Tragödie, das andere Mal als Farce

Dear Ken:

  I am using "LFS 6.0 Release" reading online off linuxfromscratch.org and 
working as the user lfs. 

 The issue seemed to be that config.log indicates ld cannot be found even 
though it is in the path in /usr/bin along with gcc.

 However, your e-mail allowed me to figure it out based on this contradiction 
and the following factoids.

1. Root user can successfully configure binutils, lfs user cannot.
2. gcc and ld are in the path.

 In going back to the creation of the lfs user I can see that in my zeal, I 
created a bash_profile, but not a bash_rc and that is the root of the 
problem. Once I created a bash_rc per the book version 6, configure succeeded 
and binutils is "making".

 I do have one followup question, however.

 I can see that the book contemplates binutils-2.15.91.0.2, but the wget 
script on linuxfromscratch.org "lfs-6.1-testing-20050129.wget" wgets binutils 
2.15.94.0.2. 

 Should I be concerned about this one and have I made a mistake with the wget 
script?

With Respect, Charles Krinke





 I can see that config.log indicates the configure script cannot find 'ld'. 
This is puzzling as when I invoke ld from the bash prompt as the lfs user, 
'ld' says "no input files", not "command not found", so the path 
to /usr/bin/ld is working as is the path to /usr/bin/gcc.

 One interesting note. If I run the configure script as the root user, the 
configure script succeeds. There must be something in the permissions or 
environment variable of the lfs user as setup in 



More information about the lfs-support mailing list