Kernel-panic ... damn, oh damn

DJ Lucas dj at linuxfromscratch.org
Sun May 8 21:40:22 PDT 2005


Kristian Poul Herkild wrote:
> After 4 (or 5 days? - can't remember it by now) of hard work to install
> LFS6.0 I now have a bootable system... almost :P
> 
> After 45 minutes of intense fighting with Grub I managed to get past the
> error 15 and later an error 1 ... somehow it couldn't figure out that
> (hd1,0) was /boot ... so it couldn't find /boot/lfskernel-2.6.8.1 ...
> 
> That works now. But after having mounted the partitions, LFS comes up
> with this n00b-error (I'm the n00b): >>Kernel panic. No init found. Try
> passing init= option to the kernel.<<
> 
> That's fine... if I knew what to pass to the kernel. Have I missed a
> configuration file or what? I've been reading and reading on google, and
> I just get's more and more confused. And it's frustrating because I know
> it's simple - I just can't see the solution :(
> 
> Kind Regards
> Kristian Poul Herkild

BLFS support? Wrong list..but I've done that plenty of times.  :-)
Replied to both so the thread is in the correct list.  Anyway, not quite
enough info to give specific instructions.  Need to know the device name
for the root partiton, and the /boot partiton.  Right now, I see the
/boot partition is /dev/hdb1.  Just a tip to help you through the
previous error, if you have separate boot partition, you are looking for
/lfskernel-2.6.8.1 (not /boot/lfskernel...) in the find command.  For
the new error, the kernel is looking at the root partition it was told
to look at, and searching for '/sbin/init'.  Select the new entry and
edit it (e) and add init=/bin/bash to the end of the kernel line.
That'll get you started.  If that gives the same error, then perhaps you
have the root=/dev/hd?? option wrong in the grub config file.

Hope that'll get you going in the right direction, if not, please post
the results along with the other requested info.

-- DJ Lucas




More information about the lfs-support mailing list