Fwd: glic 2.3.4 and glic 2.3.5 fail to build

Arnav Dhiman arnavkd at gmail.com
Tue May 17 14:48:06 PDT 2005


---------- Forwarded message ----------
From: Arnav Dhiman <arnavkd at gmail.com>
Date: May 17, 2005 12:01 PM
Subject: glic 2.3.4 and glic 2.3.5 fail to build
To: LFS Support List <lfs-support at linuxfromscratch.org>


Hi,

I am trying to build lfs 6.1 on fedora core 3. I saw the following
error in glibc 2.3.4 (in the second stage - chapter 6 of the book).

/home/build/usr/src/glibc-build/libc_pic.a^
gcc -B/tools/bin/   -nostdlib -nostartfiles -r -o
/home/LFS/build/usr/src/glibc-build/elf/librtld.map.o '-Wl,-('
/home/LFS/build/usr/src/glibc-build/elf/dl-allobjs.os
/home/LFS/build/usr/src/glibc-build/libc_pic.a -lgcc '-Wl,-)'
-Wl,-Map,/home/LFS/build/usr/src/glibc-build/elf/librtld.mapT^
/tools/bin/ld: errno: TLS definition in
/home/LFS/build/usr/src/glibc-build/libc_pic.a(errno.os) section .tbss
mismatches non-TLS reference in
/home/LFS/build/usr/src/glibc-build/elf/dl-allobjs.os
/home/LFS/build/usr/src/glibc-build/libc_pic.a: could not read
symbols: Bad value
collect2: ld returned 1 exit status
make[3]: *** [/home/LFS/build/usr/src/glibc-build/elf/librtld.map] Error 1
make[3]: Leaving directory `/home/LFS/build/usr/src/glibc-2.3.4-20040701/elf'
make[2]: *** [elf/subdir_lib] Error 2
make[2]: Leaving directory `/home/LFS/build/usr/src/glibc-2.3.4-20040701'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/LFS/build/usr/src/glibc-build
make: *** [/home/LFS/log/glibc-2.3.4-20040701-tools] Error 2

Then I tried glibc 2.3.5 also and got the same error.

Have you guys seen this error before. Could some one suggest me what
is wrong here?

Thanks

Arnav



More information about the lfs-support mailing list