Problem with dynamic linking

David Lyne davelargeuk2 at
Thu Nov 3 08:17:46 PST 2005

Hi Ken

>   However, I just googled, and maple advocates will no doubt argue that 
> (1) is the answer:  this url seems to be the same problem.  (watch for
> wrapping, on the version of pine that I'm using, anything might happen!)

Hmm. I need to improve my googling skills 8o(.

I've just done the following: (and apologies for dodgy line wraping)

$ export LD_ASSUME_KERNEL=2.2.5 && ldd /usr/bin/awk
/bin/sh: error while loading shared libraries: cannot open 
shared object file: No such file or directory

so I think we've found the problem. Thanks Ken 8o)

>  That has a link to a possible solution at

I've tried editing the file that it suggests (with vim), but because it 
seems to be a mixture of shell script and binary, it gets corrupted 
whenever I save it. (What I mean is, when I view the file with less or 
vim, the top part is all ascii characters, but the bottom part is all 
unreadable.) When I run the file again after saving whatever changes I 
make it dies while extracting itself.

>  BTW, isn't this a blfs-support issue ? :-)

Well, I guess it is now. Originally I thought I'd messed up something 
with the linker itself, which would (I think?) have been an LFS issue.

Thanks for you help again - I really appreciate your friendliness.


More information about the lfs-support mailing list