p54 'make -C ld clean' -> no ld directory

Micheal E Cooper mcooper at miyazaki-mic.ac.jp
Thu Nov 3 17:52:20 PST 2005

Newly joined the list. Nice to meet you. I very much appreciate LFS, and I
hope that someday in the not-so-distant future, I will be able to
contribute to it. However, for the time being, I am still learning.
Wonderful project this is.

If I end up violated etiquette, please tell me and I will change my behavior.

Now onto my problem:

After I went through the bin-utils "configure - make - make install"
sequence, I tried to execute the commands on page 54:
make -C ld clean
But an error tells me that there is no such directory as ld.

The only thing that I can think would have caused a problem is that, the
first time I tried to compile and install bin-utils, I did it using the
time function, with the syntax on LFS page 53. It gave me a time to use
for my SBU, but nothing was written to /tools. When I then did the
commands separately, in the order they are written in the book, some
things were installed in /tools. However, I still get the "no ld
directory" error when I try to do 'make -C ld clean'.

Since I did everything in exactly the order in the book as user lfs, I was
still in my binutils-build directory, when I did the 'make -C ld clean.'
Thinking that maybe I was in the wrong place, I checked /tools to see if
there was an ld dir, but there wasn't.

I have followed the book directions exactly, not customizing anything. I
am using LFS 6.1, the stable version. My host system is FC4 default
install. I am using packages copied from the latest LFS Live CD, and I
confirmed that they are the same versions as the ones in the LFS book I am
using, so I don't think packages are the problem. The only thing that
might be relevant is the fact that the copied-over files belong to
mcooper, not user lfs. Since the perm are 644, I did not think that was
part of the problem.

Running config.guess from binutils gave me i686-pc-linux-gnu as the target
triplet, and upon examination of my /lib directory, I found ld-linux.so.2,
implying that my host system is pretty much like the vanilla environment
described in the book.

Also, I looked at the errata on the LFS site and checked the FAQs, but I
did not see anything that looked like it might be relevant.

More information about the lfs-support mailing list