5.7 gcc --print-file specs segmentation fault

Micheal E Cooper network-admin at miyazaki-mic.ac.jp
Tue Nov 8 16:29:52 PST 2005

"Dan Nicholson" <dbn.lists at gmail.com>:

> About the copy and paste.  I've never used the LiveCD, but I'm

Thank you. I now know, or have been re-informed, about the middle button.
I have been using RHEL for so long that I forgot about it.

> Next,
> which gcc
> Does this return /usr/bin/gcc or /tools/bin/gcc?  It should be
> /tools/bin/gcc.  If not, you have not set PATH correctly in
> /home/lfs/.bashrc.  Or, your gcc-pass1 build failed.

I am pretty sure that the first time I ran it, it was under /usr/bin/gcc,
and I thought that was not good. Looks like I was right.

> Next, what's the output of
> gcc --print-file specs
> Just entering this at the command line should give you a path.

The first time I entered it, it was something under /usr, and the second
time, after I ran the long command, I got a segfault.

> I would restart from Ch. 5.4 with gcc.  And if you don't know

I think that is what I will do. I understand the process in theory, but
the specifics and subtleties do jump up on you, don't they? Very fun. Very
educational. Really enjoying it.

I think I will reboot for good measure, too. I haven't rebooted at all
since I began, because it is a pain to go through configuring the X11,
mounting the HDD, etc. all over again. But hey, that's learning, too.

Thank you very much.

More information about the lfs-support mailing list