udev confusion

Joerg Balsiger joergbalsiger at yahoo.com
Tue Nov 29 05:59:35 PST 2005

Dear all, 

My head is buzzing with udev rules, buses and devices - I hope somebody can
help me sort this out (I've read the man pages, the March 2005 LFS-support
thread on udev rules, as well as the various, unfortunately very
gentoo-oriented, guides for writing udev rules):

I have a laptop with a cdrw drive that stopped working, so I uncommented the
LFS 6.1-derived udev rule for recognizing the cdrom. (I use (B)LFS 6.1, but
have upgraded to a 2.6.15-rc2-mm1 kernel and udev 076)

Now I bought a usb-connectable dvd-rw (Samsung Writemaster SE W164) and am
trying to get it to work with udev. I also have a usb-connectable hard drive -
both devices connect to the laptop via a usb hub.

When I connect the dvd-writer, dmesg reports:

sr0: scsi3-mmc drive: 8x/48x writer cd/rw xa/form2 cdda tray
sr 6:0:0:0: Attached scsi CD-ROM sr0
sr 6:0:0:0: Attached scsi generic sg0 type 5

So I thought a udev rule like so (TSSTcorp is the vendor reported in

SYSFS{vendor}=="TSSTcorp", NAME="dvd", SYMLINK="dvd"

and a line in /etc/fstab like so:

/dev/dvd /media/dvd   auto  user,noauto,noatime   0     0

would unequivocally identify the device and allow me to mount it.

But when I insert a data dvd and try to mount it with:

mount -t auto /dev/dvd /media/dvd

I'm told that it is not a block device (I've also tried 

mount -t auto /dev/sr0 /media/dvd

but get the same error).

I'm afraid to start using udev rules involving KERNEL=="hdc" because a
replacement cdrw is on the way and I'd like to keep the two apart.

What am I doing wrong? Is there a part of this interconnected system that needs
a hd* or sd* to recognize the usb dvd-writer as a block device when it has a
data dvd inserted? It's not a permission issue either, I've checked that...

Utter confusion ;-(

Thanks for any help...


Start your day with Yahoo! - Make it your home page! 

More information about the lfs-support mailing list