book/package error concerning bash-3.0

Vladimir A. Pavlov pv4 at bk.ru
Thu Jun 1 14:16:20 PDT 2006


Michiel Faber wrote:
> Hello,
>
> The first command in chapter 6.37.1 of lfs 6.1.1 is:
>
> tar -xvf ../bash-doc-3.0.tar.gz &&
>
> however the package i downloaded from a mirror ftp-server is named
> "bash-doc-3.0.tar.bz2" and not "*.gz"
> The command should thus be:
>
> tar -xjvf ../bash-doc-3.0.tar.bz2 &&
>
> Not a big issue, but maybe needs to change in the book?
>
> Michiel

AFAIK when called with -xvf (without -j/-x) tar automatically determines 
the archiver to use (bzip2/gzip). So you can download file with any of 
the extensions and use the command from the book.

-- 
Nothing but perfection
pv



More information about the lfs-support mailing list