glibc-2.3.4 make error gconv.o

Steven Vancoillie steven.vancoillie at chem.kuleuven.be
Mon Jun 19 10:45:09 PDT 2006


Hi,

This is my first post on lfs-support and mailing lists in general.
(I did read the netiquette and stuff). Just for information: this is
also my first try at setting up lfs.

Following the LFS-book 6.1.1, in chapter 5.6 I tried to compile 
glibc-2.3.4 with gcc.4.0.3 (host ubuntu 6.06 kernel 2.6.15-25-386) and 
it failed with an error concerning gconv.o.

I'm not posting the error message, as I found the same thing on these 
mailing list archives and there someone stated that compiling 
glibc-2.3.4 with gcc 4 and beyond was a problem:

http://archives.linuxfromscratch.org/mail-archives/lfs-dev/2006-March/056418.html

I then downloaded glibc-2.3.6 and tried to compile that with gcc-4.0.3, 
which worked!

My question: are there any obvious reasons why glibc-2.3.6 would give 
problems if I use it in LFS 6.1.1? I want to keep gcc-3.4.3 on my final 
LFS-system, will this work with glibc-2.3.6?
The book does say I need version gcc 3.0 or later, but apparently not 
after gcc 4?

If I should stick with the book: how can I easily use gcc-3.4 on my 
host? The packages are allready installed, but I'm not sure if I can 
just use /usr/bin/gcc-3.4 and how to point the glibc-2.3.4 configure 
script to this version?

To conclude: which options seems best:
1) using glibc-2.3.6 in lfs 6.1.1
2) trying to use gcc-3.4 and keep glibc.2.3.4, in which case I'm 
wondering how to make the configure script of glibc-2.3.4 use gcc-3.4?
(I never edited any configure script or Makefile before and I'm a bit 
lost there)

I hope this message is a bit clear :)

all the best,
and thanks for any help you can give me,

Steven

Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm




More information about the lfs-support mailing list