glibc-2.3.4 make error gconv.o

Dan Nicholson dbn.lists at gmail.com
Mon Jun 19 11:11:53 PDT 2006


On 6/19/06, Chris Staub <chris at beaker67.com> wrote:
> Steven Vancoillie wrote:
> >
> > I'm not posting the error message, as I found the same thing on these
> > mailing list archives and there someone stated that compiling
> > glibc-2.3.4 with gcc 4 and beyond was a problem:
> >
> You should not use any different versions from what's in the book. If
> you follow the instructions in the book, it *will* work. You shouldn't
> even be compiling glibc with GCC 4 since LFS 6.1.1 uses GCC 3.4.3. If
> you *are* using the host's compiler, it is because you missed a step
> somewhere. What is the output of these commands, as the lfs user...
>
> echo $PATH
> ls /tools/bin/gcc

Oh yeah.  Way to pull out the cluebat, Chris!  Since you built
gcc-3.4.3 in the gcc-pass1 stage, glibc should be built using that
compiler as long as it comes first in your PATH.

--
Dan



More information about the lfs-support mailing list