Anyone succesfully set up LFS on colinux?

Wei Hu wei.hoo at gmail.com
Fri Jun 30 13:52:07 PDT 2006


Hi there,

I've searched the internet but didn't see any posts related to my problem.

Before I installed LFS I was using colinux-0.7.1-hn15 (with kernel
2.6.12 patched by colinux) and gentoo.
Recently I tried to install LFS SVN-20060619 on top of colinux.

However, after I set up everything and reboot, udev seemed to not work properly.
After it output "Populating /dev with device nodes" for a while it
reported a red [Failure] to me.
Afterwards a lot of programs reported errors related to some files or
devices missing, and then the system froze.

udev also complained that the file /proc/sys/kernel/hotplug was missing.
Since I didn't rebuild kernel and simply used the kernel shipped with
colinux, the kernel didn't have hotplug support.
So I rebuilt the kernel to enable hotplug.
However the failure of populating /dev didn't go away.

I also tried to redo Chapter 6.2 "Preparing Virtual Kernel File
Systems", and Chapter 6.55 "Udev-092".
It didn't work either.

However, if I append "init=/bin/bash" when I boot colinux, I'm able to
get a shell.

I attempted to look at the udev script to get some insight but failed.

Does anyone have suggestions?

Thanks a lot,
Wei



More information about the lfs-support mailing list