Section 5.8

elmarsa dice elmarsadice at yahoo.com
Sat May 6 16:22:12 PDT 2006


Started section 5.8 per directions in the book.  I am installing from
the live CD.  Everything going ok till it stopped with the following
note:

checking installed linux kernal header files... TOO OLD
Configure error:  GNU glibc requires kernel header files 
from Linux-2.0.10 to be installed before configuring.
The kernel header files are found usually in /usr/include/asm
and /usr/include/linux; make sure these directories use files 
from linux 2.0.10 or later. This check uses <linux version.h>,
so make sure the file was built correctly when installing the 
kernal header files. To use kernal headers not from 
/usr/include/linux, use the configuration option --with-headers

I checked that all directories were present and I know the cd is
later than linux-2.0.10.  I did notice when doing section 5.6.1 that
the instructions say to uses asm-386 but it wasn't on the live cd so
I used asm which was.  In my tools/glibc-kernheaders directory I have
/asm /asm-generic and /linux which is as it should be.  In 
/tools/include I also have asm.  Any ideas on how to get around this
hold up is appreciated. 

elmarsa

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 



More information about the lfs-support mailing list