tty error on a debian sarge host

Georgina Joyce gena at genaj.plus.com
Fri May 12 15:43:50 PDT 2006


On Fri, May 12, 2006 at 10:52:05PM +0100, Ken Moffat wrote:
> On Fri, May 12, 2006 at 10:14:31PM +0100, Georgina Joyce wrote:
> > Hi
> > 
> > Well I'm getting the tty error as stated in the lsf FAQ.  But not sure how I can fix it.
> > 
> > I think I have right kernel options selected as I'm using a custom built 2.6.15.4 kernel and the FAQ suggests that I should have a /dev/pts option which doesn't appear in my .config.
> 
>  From memory, the option disappeared a few months ago, so any recent
> kernel ought to support /dev/pts.

> > 
> > The files in the /dev/ directory were present and I run the chmod commands and put the entry in the /etc/fstab file as suggested in the FAQ but still get the error.
> > 
> > So how do I produce tty for the final binutil build?
> > 
> 
>  You are in chapter 6 ?  For the *stable* book (6.1.1), /dev/pts and
> /dev/shm are mounted at the end of section 6.8.2.  If you interrupt
> the build and exit chroot, that part (6.8.2) has to be repeated.
Thanks, I've only got up to 6.1.3 where there's a strong urge to check the enviroment.  Which for the first time, I get the error message.

I enter chroot by running the following script:


#!/bin/sh
mount -vt proc proc $LFS/proc
mount -vt sysfs sysfs $LFS/sys
 mount -vft tmpfs tmpfs $LFS/dev
mount -vft tmpfs tmpfs $LFS/dev/shm
mount -vft devpts -o gid=4,mode=620 devpts $LFS/dev/pts
 chroot "$LFS" /tools/bin/env -i HOME=/root TERM="$TERM" PS1='\u:\w\$ ' PATH=/bin:/usr/bin:/sbin:/usr/sbin:/tools/bin /tools/bin/bash --login +h

Which are the commands given for entering chroot so far.


Regards
Gena

> 
> 
> Ken
> -- 
> das eine Mal als Tragödie, das andere Mal als Farce
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
---end quoted text---

-- 
2E0AXU

Freedom & Power provided by debian GNU Linux



More information about the lfs-support mailing list