Is these errors ok?

Ken Moffat ken at linuxfromscratch.org
Sat May 20 10:00:36 PDT 2006


On Sat, May 20, 2006 at 08:48:17AM -0700, Dan Nicholson wrote:
> On 5/20/06, Søren Christensen <soren_helskov at hotmail.com> wrote:
> >Im building on a 32bit ubuntu running on my 64bit Athlon64.
> >Is that considered as a 64bit system or a 32bit?
> 
 Provided the kernel is 32-bit (uname -m reports i686, NOT x86_64)
you are fine to follow the regular LFS book.

> In that case, you could build the straight 32 bit LFS book, but might
> still have problems.  I've never tried this, so I can't really say.
> Although, it's possible that some configure scripts, etc., may detect
> your 64 bit architecture and attempt to build 64 bit binaries.
>

 In fact, that only happens if you have a 64-bit kernel.  My main
build machine is athlon64, and at the moment it is running as a fast
i686.

> It would be safest to use the Cross-LFS technique.  Otherwise, you'll
> have to be very careful at each step of the way making sure that
> you're creating 32 bit binaries, they're being installed to the right
> locations, no features are being excluded, etc.  Sorry, that's the
> best I can say.  Maybe someone else who has tried this will chime in.
> 

 While I'm keen to get more people testing CLFS, it probably isn't
necessary if all Søren wants is a 32-bit system.  And the bar to
entry is a little higher than for regular LFS.  So, back to his
test failures, which I've pasted in:

>>make[2]: *** [/sources/glibc-build/libio/tst-fopenloc.check] Error 127
>>make[1]: *** [libio/tests] Error 2
>>make[2]: [/sources/glibc-build/posix/annexc.out] Error 1 (ignored)
>>make[2]: *** [/sources/glibc-build/posix/bug-regex2-mem] Error 127
>>make[2]: *** [/sources/glibc-build/posix/bug-regex14-mem] Error 127
>>make[2]: *** [/sources/glibc-build/posix/bug-regex21-mem] Error 127
>>make[2]: *** [/sources/glibc-build/posix/tst-rxspencer-mem] Error 127
>>make[2]: *** [/sources/glibc-build/posix/tst-pcre-mem] Error 127
>>make[2]: *** [/sources/glibc-build/posix/tst-boost-mem] Error 127
>>make[2]: *** [/sources/glibc-build/posix/bug-glob2-mem] Error 127
>>make[1]: *** [posix/tests] Error 2
>>make[2]: *** [/sources/glibc-build/nptl/tst-stack3-mem] Error 127

 Søren, which version of the book is this ? (I can't tell which
version of glibc you are testing).

 The common factor in all the unexpected failures is 'Error 127'.
I've just tried to find a definitive link on this, without success,
but my gut feeling is that it means "command not found".

 If you have the full log from which this was grepped, take a look
at it (from the host, obviously, to allow you to use less or view)
and search for these failing tests.  I'm guessing fopenloc might
have an error message about mtrace - if so, your perl installation
is broken.  In fact, I'm fairly confident that is the problem -
bug-regex2-mem mentions mtrace (I'm looking at glibc-2.3.6), and
tst-pcre-mem is obviously concerned with perl compatible regexes.

Ken
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-support mailing list