extracting gcc-4.03.tar.bz2: no space left on device

Chris Staub chris at beaker67.com
Wed Jan 3 09:34:37 PST 2007

Max Tilford wrote:
> Hello
> I am running the LFS live CD 6.2 and following the
> book.
> I have gotten to chapter 5.4 without a hitch but when
> I try to uncompress gcc-4.0.3.tar.bz2 it produces a
> long string of errors saying 
> "cannot create directory '...' No space left on
> decice"
> I am installing LFS on a 120 gigabyte hard drive, all
> one partition.  I also tried to do this on my other
> hard drives, but I got the same error.  The only
> problem I can think of is lack of RAM.  I have 512 mb
> and have mounted a 5 gigabyte swap.
> Am I doing something really stupid?
> Any advice?
> Thankyou
> Max Tilford
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around 
> http://mail.yahoo.com 

Most likely you're trying to unpack the sources from their original 
location in /lfs-sources, which is part of the CDROM and is in RAM. Try 
copying the sources elsewhere, like the book's suggested location 

More information about the lfs-support mailing list