LFS 5.4 GCC-4.0.3 make errors

Rob truktrix at carolina.rr.com
Sun Jan 21 06:15:28 PST 2007

Hello everyone.  I'm a Linux noob, so be gentle, please.

First of all, at the time of writing this, I am currently using the LFS 
LiveCD-6.2-4 as my host system on a P4 1.6Ghz 256m system.  For the last 
2 days, i was using 6.2-3.

So, I make it through the book, up to section 5.4, GCC-4.0.3 - Pass 1 
without any problems what-so-ever.  Once I come to the "make bootstrap" 
command, I get the same error every time.

config.status: creating Makefile
config.status: creating testsuite/Makefile
config.status: creating config.h
config.status: executing default commands
make[1]: Entering directory 
if [ x"" != x ] && [ ! -d pic ]; then \
 mkdir pic; \
else true; fi
touch stamp-picdir
make[1]: *** No rule to make target `../include/ansidecl.h', needed by 
.  Stop.
make[1]: Leaving directory 
make: *** [all-build-libiberty] Error 2

I have gotten to this error as I said several times, and at that point, 
re-tried the command, then started over from scratch probably 8 times 
now in the last 3 days.

Can someone help me point out my mistake?


More information about the lfs-support mailing list