LFS 5.4 GCC-4.0.3 make errors

Ken Moffat ken at linuxfromscratch.org
Sun Jan 21 06:32:12 PST 2007

On Sun, Jan 21, 2007 at 09:15:28AM -0500, Rob wrote:
> Hello everyone.  I'm a Linux noob, so be gentle, please.
> First of all, at the time of writing this, I am currently using the LFS 
> LiveCD-6.2-4 as my host system on a P4 1.6Ghz 256m system.  For the last 
> 2 days, i was using 6.2-3.
> So, I make it through the book, up to section 5.4, GCC-4.0.3 - Pass 1 
> without any problems what-so-ever.  Once I come to the "make bootstrap" 
> command, I get the same error every time.

> make[1]: *** No rule to make target `../include/ansidecl.h', needed by 
> `regex.o'
> .  Stop.
> make[1]: Leaving directory 
> `/mnt/lfs/gcc-build/gcc-4.0.3/build-i686-pc-linux-gnu
> /libiberty'
> make: *** [all-build-libiberty] Error 2

 This header should be in /usr/include.  Is it ?  The LiveCD can be
expected to be a known good host, but I'm not familiar with what has
to be done when mounting it.

> I have gotten to this error as I said several times, and at that point, 
> re-tried the command, then started over from scratch probably 8 times 
> now in the last 3 days.

 That is probably a misplaced willingness to restart - until you
have at least a theory about what went wrong, it is unlikely to
> Can someone help me point out my mistake?
> Thanks,
> Rob
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page

das eine Mal als Tragödie, das andere Mal als Farce

More information about the lfs-support mailing list