LFS-6.5 Chapter6.51-Psmisc

Stephan Jansen stephan.jansen at acoustic5.de
Thu Oct 15 01:06:53 PDT 2009

I've got the same error at the same point as Scott Castaline reports at
25 Sep 2008: When I do ./configure --prefix=/usr --exec-prefix="" to
configure psmisc, the process terminates with
"configure: error: Cannot find tinfo, ncurses or termcap libraries".
I have reinstalled ncurses round about three or more times but it does
not solving the problem. Thereby I tried out to configure with or
without different options, but at last I followed the book originally.
Maybe a piece of interest: A similar problem occured before when
installing readline: Compiling ("make")  ended up with two errors: one
was reported as "ignored", the other was a syntax error regarding to
libncurses.so or libncursesw.so so I recognize.
I've tried to install anyway and there seemed to be no problem, readline
installed without any error prompt. So I went on until building perl was
unpossible to install, but I'm sorry, at this time I do not remember the
error-messages accurately.
I give up my first attempt and began a new up from chapter 5 (I backed
up the first toolchain). Now I have builded readline without the
SHLIB_LIBS=-lncurses option and in the following there were no problems
to install perl (why ever). But now there is this annoying problem with
config of psmisc.
I'm really not an expert, but it seemed to me somewhat like a
linker-problem (insofar I have understood the system - please correct me
if I'm wrong).
I would be really gratefull for every hint leading closer to any
solution - I'm at a loss.
If there is any need for more information please tell me - I will try to
reproduce the occuring errors but because of my workaround I'm not able
to copy and paste the prompting messages so it is a little bit extensive
to post them.

Thank you

More information about the lfs-support mailing list