Disable rutine that drops you to a shell on reboot

Michael L. lfs-support at cosis.dk
Fri Oct 16 12:12:15 PDT 2009

Ken Moffat wrote:

Hi Ken,

It worked like a charm :-D

Thanks for your help - it was just what I needed :-D

Best Regards
> 2009/10/16 Michael L. <lfs-support at cosis.dk>:
> Ah.  I think I've had the same problem (it fails during the netfs script).
> In my case, that was on a CLFS build, and I assumed something in
> that toolchain was causing the problem.  Commenting the following
> chunk of code in the netfs script worked around it for me.:
>                         # Try and stop processes the nice way
>                         # (probably won't work in most cases)
>                         /bin/fuser -SIGTERM -km $NETMOUNTS > /dev/null
>                         # Check and see if it found anything.  If it
>                         # did, then give 3 seconds for things to exit
>                         # the nice way before killing them off.
>                         # This one will work all of the time!
>                         if [ $? = 0 ]
>                         then
>                                 /bin/sleep 3
>                                 /bin/fuser -km $NETMOUNTS > /dev/null
>                         fi
> After that, it continues to umount _netdev, and then to umount by
> fstype, so commenting the code on a desktop doesn't seem to
> cause any problems.
> All I've established so far is that the call to fuser with -SIGTERM
> is described as 'Terminated' (status 143) if run manually, and the
> second call is described as 'Killed' (status 137).  I've been
> assuming something in the clfs toolchain might have caused fuser
> to be miscompiled [ mid-September book, with 2.6.31 headers.
> If this is LFS, and your problem turns out to match, then it might
> be a general problem with psmisc-22.8.
> FWIW, trying to run strace didn't do a lot of good (strace
> appeared to be killed by the SIGTERM).
> ĸen

More information about the lfs-support mailing list