"Cannot run C compiled programs", falling at first hurdle.

Christian Gardner christian_gardner at yahoo.co.uk
Mon Oct 26 04:22:28 PDT 2009

Never mind peeps, I worked out what it was. Just in case anyone's as dumb as me, here's what happened. I stick all the LFS instructions in a bash script, which doesn't fail as sensibly as it should. The first time I ran it, binutils compiled but gcc didn't (for separate reasons I've now fixed). The script ploughed on, trying and failing to compile anything else.

Then it got to the toolchain adjustment, where everything gets linked to /tools/lib instead of just /lib. Since the former didn't have anything useful in it (as gcc-1st-pass didn't work out), that meant nothing would ever compile properly anymore! I fixed it by changing the gcc specs back. Now it's all smooth. Well at least as far as the chroot... I haven't tested further yet.

Ta anyway

Send instant messages to your online friends http://uk.messenger.yahoo.com 

More information about the lfs-support mailing list