"Cannot run C compiled programs", falling at first hurdle.

Simon Geard delgarde at ihug.co.nz
Mon Oct 26 23:49:11 PDT 2009

On Mon, 2009-10-26 at 04:22 -0700, Christian Gardner wrote:
> Never mind peeps, I worked out what it was. Just in case anyone's as
> dumb as me, here's what happened. I stick all the LFS instructions in
> a bash script, which doesn't fail as sensibly as it should. The first
> time I ran it, binutils compiled but gcc didn't (for separate reasons
> I've now fixed). The script ploughed on, trying and failing to compile
> anything else.

A hint for writing scripts like that - running "set -e" at the top
causes the script to terminate if any subsequent command fails.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20091027/58cfc6c8/attachment.sig>

More information about the lfs-support mailing list