Make error in glibc

gaurav k gk_manutd at yahoo.co.in
Tue May 4 21:57:15 PDT 2010


I'm STILL getting the same error. I'm really clueless now.

I deleted the glibc-build directory. I re-extracted the source code... but no cigar.

I'm inside the extracted glibc directory, and this is what I do:

$mkdir -v ../glibc-build
$cd ../glibc-build
$echo "CFLAGS += -march=i486 -mtune=native" > configparams
$../glibc-2.11.1/configure --prefix=/tools --host=$LFS_TGT --build=$(../glibc-2.11.1/scripts/config.guess) --disable-profile --enable-add-ons --enable-kernel=2.6.18 --with-headers=/tools/include/ libc_cv_forced_unwind=yes libc_cv_c_cleanup=yes
$make



What I tried was, I redirected the output of the following command to a file:

$../glibc-2.11.1/configure --prefix=/tools --host=$LFS_TGT --build=$(../glibc-2.11.1/scripts/config.guess) --disable-profile --enable-add-ons --enable-kernel=2.6.18 --with-headers=/tools/include/ libc_cv_forced_unwind=yes libc_cv_c_cleanup=yes > file.txt

and so was able to see the following on the shell:

configure: WARNING: using cross tools not prefixed with host triplet
configure: WARNING:
*** These auxiliary programs are missing or incompatible versions: msgfmt makeinfo autoconf
*** some features will be disabled.
*** Check the INSTALL file for required versions.
configure: WARNING: cpuid.h: present but cannot be compiled
configure: WARNING: cpuid.h:     check for missing prerequisite headers?
configure: WARNING: cpuid.h: see the Autoconf documentation
configure: WARNING: cpuid.h:     section "Present But Cannot Be Compiled"
configure: WARNING: cpuid.h: proceeding with the preprocessor's result
configure: WARNING: cpuid.h: in the future, the compiler will take precedence



I'm guessing THIS is the real problem?


Could someone please tell me how do I go about fixing this?


(Bruce & Chris- thank you for replying!)



From: Chris Staub <chris at beaker67.com>
To: LFS Support List <lfs-support at linuxfromscratch.org>
Sent: Mon, 3 May, 2010 11:40:03 PM
Subject: Re: Make error in glibc

On 05/03/2010 10:24 PM, gaurav k wrote:
> Hey Guys,
>
> This is my first mail to the list- I'm a relative newbie- though not a
> complete Linux noob who is clueless about what is happening.
>
> I have not deviated from the book at all, the only possible difference
> might be any differences in the host system requirement. For example,
> /bin/sh is not a symlink to bash, but I've only used bash throughout.
>

Yeah, that's not a problem.
>
> I went through a few of the mail archives, and I realized that I had
> made a mistake in the configparams file - I have rectified it.
>
> $ cat configparams
> CFLAGS += -march=i486 -mtune=native

The problem with configparms would definitely be the cause of the errors 
you got, so they should have gone away once you redid it. Did you remove 
the source/build directories before trying again?

>
> My extracted glibc is a subfolder of an independent folder glibc-build.

This is incorrect. Please see page 5.3, particularly in this case the 
last "Note" box. It says that for each package, you must unpack the 
package tarball, cd into the source dir, *then* follow instructions on 
the installation page. Therefore, you should already be in Glibc's 
source directory when you create the build dir.

Also, if you have managed to create /mnt/lfs/glibc-build, you had to 
have either chowned/chmodded /mnt/lfs, or created glibc-build as root 
(or using sudo), neither of which the book says to do. If you did use 
chown or chmod on /mnt/lfs, you should change it back (owned by root, 
755 perms).
-- 
http://linuxfromscratch.org/mailman/listinfo/lfs-support
FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page







More information about the lfs-support mailing list