Make error in glibc

gaurav k gk_manutd at yahoo.co.in
Wed May 5 18:14:34 PDT 2010


Hey Guys... 

I just thought I'd let you all know how it turned out.

Chris, you were absolutely right. There was a package missing.  I had followed "host system requirements", but it seems that autoconf is needed too. Ubuntu Lucid does not have it installed by default. If you see the output I have pasted below- you'll see that autoconf was missing. It is not mentioned in the "host system requirements". It worked as soon as I installed it.


Simon- I really know just the basics about how bash works- but thank you for pointing out that scripts might use /bin/sh- I had no clue! But dash worked for me - luckily! 


Thank you for your help guys! 

-----
Gaurav




----- Original Message ----
From: Chris Staub <chris at beaker67.com>
To: LFS Support List <lfs-support at linuxfromscratch.org>
Sent: Wed, 5 May, 2010 1:17:28 AM
Subject: Re: Make error in glibc

On 05/05/2010 12:57 AM, gaurav k wrote:
> I'm inside the extracted glibc directory, and this is what I do:
>
> $mkdir -v ../glibc-build
> $cd ../glibc-build
> $echo "CFLAGS += -march=i486 -mtune=native">  configparams

Assuming this is a literal copy of what you actually typed, this is 
incorrect. It's "configparms" not "configparams".

> $../glibc-2.11.1/configure --prefix=/tools --host=$LFS_TGT --build=$(../glibc-2.11.1/scripts/config.guess) --disable-profile --enable-add-ons --enable-kernel=2.6.18 --with-headers=/tools/include/ libc_cv_forced_unwind=yes libc_cv_c_cleanup=yes
> $make
>
>
>
> What I tried was, I redirected the output of the following command to a file:
>
> $../glibc-2.11.1/configure --prefix=/tools --host=$LFS_TGT --build=$(../glibc-2.11.1/scripts/config.guess) --disable-profile --enable-add-ons --enable-kernel=2.6.18 --with-headers=/tools/include/ libc_cv_forced_unwind=yes libc_cv_c_cleanup=yes>  file.txt
>
> and so was able to see the following on the shell:
>
> configure: WARNING: using cross tools not prefixed with host triplet
> configure: WARNING:
> *** These auxiliary programs are missing or incompatible versions: msgfmt makeinfo autoconf
> *** some features will be disabled.
> *** Check the INSTALL file for required versions.
> configure: WARNING: cpuid.h: present but cannot be compiled
> configure: WARNING: cpuid.h:     check for missing prerequisite headers?
> configure: WARNING: cpuid.h: see the Autoconf documentation
> configure: WARNING: cpuid.h:     section "Present But Cannot Be Compiled"
> configure: WARNING: cpuid.h: proceeding with the preprocessor's result
> configure: WARNING: cpuid.h: in the future, the compiler will take precedence
>
>
>
> I'm guessing THIS is the real problem?

No idea (though I think the above misspelling of configparms is the real 
issue), but the message about not finding makeinfo does also indicate 
that you've missed a page. See "Host System Requirements" and make sure 
you actually do have everything listed there.
-- 
http://linuxfromscratch.org/mailman/listinfo/lfs-support
FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page







More information about the lfs-support mailing list