Make error in glibc

Bruce Dubbs bruce.dubbs at gmail.com
Wed May 5 18:30:57 PDT 2010


gaurav k wrote:
> Hey Guys...
> 
> I just thought I'd let you all know how it turned out.
> 
> Chris, you were absolutely right. There was a package missing.  I had
> followed "host system requirements", but it seems that autoconf is
> needed too. Ubuntu Lucid does not have it installed by default. If
> you see the output I have pasted below- you'll see that autoconf was
> missing. It is not mentioned in the "host system requirements". It
> worked as soon as I installed it.

I can certainly add autoconf to the host requirements, but the last time 
we checked, it was not a prerequsite for glibc.  It should only be 
needed if configure.in is modified.  We certainly build glibc in Chapter 
6 without autoconf.

> Simon- I really know just the basics about how bash works- but thank
> you for pointing out that scripts might use /bin/sh- I had no clue!
> But dash worked for me - luckily!

In the past, dash did not work.  It may be version dependent.  I still 
think bash is the better option.

   -- Bruce



More information about the lfs-support mailing list