Glibc make fails with Error 2

Kyle Brennan kyle_bren at live.com
Sun May 23 20:29:17 PDT 2010


On 05/23/2010 08:07 PM, Kyle Brennan wrote:
> On 05/23/2010 07:05 PM, Kyle Brennan wrote:
>    
>> On 05/23/2010 06:49 PM, Bruce Dubbs wrote:
>>
>>      
>>> Kyle Brennan wrote:
>>>
>>>
>>>        
>>>> On 05/23/2010 06:07 PM, Bruce Dubbs wrote:
>>>>
>>>>
>>>>          
>>>>> Kyle Brennan wrote:
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>            
>>>>>> /mnt/lfs/tools/bin/../lib/gcc/i686-lfs-linux-gnu/4.4.3/../../../../i686-lfs-linux-gnu/bin/ld:
>>>>>>
>>>>>>
>>>>>>
>>>>>>              
>>>>>
>>>>>            
>>>>>> cannot find -lgcc_eh
>>>>>>
>>>>>>
>>>>>>
>>>>>>              
>>>>> It looks like a problem with the gcc build. You should have:
>>>>>
>>>>> /mnt/lfs/tools/gcc/x86_64-unknown-linux-gnu/4.4.3/libgcc_eh.a or
>>>>> /mnt/lfs/tools/gcc/i686-pc-linux-gnu/4.4.3/libgcc_eh.a
>>>>>
>>>>>        -- Bruce
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>            
>>>> I got it from the tarball that was on the linux from scratch site.
>>>> there may be a problem with my host system.  because when i was building
>>>> in the tools directory I did not reinstall.  there may be a error there
>>>> because there is supposed to be a symlink there right? so if that is
>>>> correct, I would need to fix my host system.
>>>>
>>>>
>>>>          
>>> There wouldn't be a problem as long as you didn't install anything over
>>> a file in the /usr tree, but I suggest you delete /tools and any
>>> subdirectories in /mnt/lfs/sources and completely and start over.
>>>
>>>       -- Bruce
>>>
>>>
>>>        
>> Just an update now that I checked, I do have some directories in the
>> $LFS/tools directory.  I will remove them and try building it all again.
>>
>>      
> so I was running the gcc configure and I saw this warning message.  I
> wanted to check to see if it was normal or not.
>
> checking whether we are using the GNU C++ compiler... no
> checking whether g++ accepts -g... no
> checking for gnatbind... no
> checking for gnatmake... no
> checking whether compiler driver understands Ada... no
> checking how to compare bootstrapped objects... cmp --ignore-initial=16
> $$f1 $$f2
> checking for version 0.10 of PPL... no
> checking for correct version of CLooG... no
> *** This configuration is not supported in the following subdirectories:
>        target-libada gnattools target-libstdc++-v3 target-libgfortran
> target-libffi target-zlib target-libjava zlib target-libobjc
> target-libgomp target-libmudflap target-libssp target-boehm-gc
>       (Any other directories should still work fine.)
> checking for bison... bison -y
> checking for bison... bison
> checking for gm4... no
> checking for gnum4... no
> checking for m4... m4
>
>    --Kyle
>    
  Bruce,
I think I figured it out.  when I was looking at the Gcc compile 
instructions, it wanted to make a symlink to the libgcc_eh.a but I do 
not think that I made that link properly.  I will work on that as well.  
I will get that fixed and then post again if it works.



More information about the lfs-support mailing list