[lfs-support] LFS 7.0 - broken bash build - command substitution: syntax error near unexpected token `)'

Tom Blamer blamer at gmail.com
Tue Jan 3 07:35:02 PST 2012


Thank you for this hint. I am using LFS 7.0 on an Xubuntu Lucid 32bit on an
old

> Pentium 4 -> x686. I followed the instructions of the book exactly. But the
> build of bash in chapter 5 failed because there was no yacc. So I installed
> byacc from ubuntu packages. After that Bash built and as recommended I
> skipped
> the test suite. I had no problems until I tried to build glibc in chapter
> 6. The
> first error occured in the chroot environment when I performed
>
> DL=$(readelf -l /bin/sh | sed -n 's at .*interpret.*/tools\(.*\)]$@\1 at p')
>
> syntax error near unexpected token `)'
>
> I worked this around, but the build of glibc failed with the same error
> message!
> The bash on the host system had of course no problem to perform the
> "DL=$(....)"
> command. So it seems to be a problem with bash's parser.
>
> I solved this problem by removing byacc on the host system, installing
> bison and
> re-building bash. I didn't finish LFS, yet, but it seems to work. At least
> I was
> able to build glibc! Perhaps there could be a section in the next release
> of LFS
> to ensure the right yacc binary??


Interesting. So installing Xubuntu's bison package gave you a yacc binary?
On Fedora 16 I don't think it did, so the only way I could install yacc was
with byacc, so I was kind of stuck. However, I haven't been on my host
system to check recently.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120103/8a131586/attachment.html>


More information about the lfs-support mailing list