[lfs-support] LFS -Chapter 6.4 - CHROOT - Frustrating me badly.... I've tried so many things...

Austin Jones austin.jones231 at gmail.com
Wed Jan 4 20:52:37 PST 2012


I encountered the same problem about a week ago. Be sure to check that the partition you have LFS on is actually mounted, as sometimes when your host boots it will not mount it automatically. 

On Jan 4, 2012, at 11:25 PM, <jasonpsage at jegas.com> wrote:

> Hello Folks,
> 
> I need more help I'm afraid. 
> 
> Error Message: chroot failed to run command '/tools/bin/env' : No such
> file or directory
> 
> I've confirmed it's there: /mnt/lfs/tools/bin/env
> I've made sure $LFS = /mnt/lfs
> I've executed the command directly and get a list of environment
> variables. Thinking this might be wrong,
> I even tried:
> 
> /mnt/lfs/tools/bin/env --help     
> 
> And I got Help!  I even tried the chroot in $LFS/tools/bin/ just to see
> what would happen - SAME ERROR
> 
> Does anyone know what this could be? It seems so simple a thing and yet
> its preventing me from moving forward and I really really want to keep
> moving forward if possible.
> 
> Any ideas?
> 
> Thank You!
> --Jason
> 
> 
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page



More information about the lfs-support mailing list