[lfs-support] LFS -Chapter 6.4 - CHROOT - Frustrating me badly.... I've tried so many things...

jasonpsage at jegas.com jasonpsage at jegas.com
Thu Jan 5 03:55:08 PST 2012


>> I need more help I'm afraid. 
>> 
>> Error Message: chroot failed to run command '/tools/bin/env' : No such
>> file or directory
>> 

>What do you get when you run (on your host system):
> ldd /tools/bin/env
>
>If it lists anything in /lib or /usr then you've made a mistake
>somewhere. It should only list things in /tools.

You always have good ideas and things to try!
I tried it and I received nothing in the /lib or /usr HOWEVER its
been hours since I posted that and I've been reworking my scripts 
alot after chroot issue, not having that issue when I did book by hand, 
and after getting bit from not wiping a source directory after I used
it making a subsequent compile (binutils) fail.


So it's taking a lot of work but I think my scripting modifications will
pay
off as they mimic the book exact now. Example: I was downloading all
then unzipping 
all and then ripping through the compiling. Now I'm doing this for EVERY
COMPILE:

REMOVE PREEXISTING SOURCE DIR
UNZIP SOURCE DIR
FOLLOW LFS BOOK Instructions
MOVE ON TO NEXT

I'm doing this methodically through all my scripts to try and eliminate
chroot and any other potential 
problems I might of set myself up for.

So please don't think your message was a waste - I look forward to your
responses! :) 

Thank You VERY MUCH!! 

Still HAcking,
Jason




More information about the lfs-support mailing list