[lfs-support] LILO and GRUB - LILO I can make work, GRUB often leaves me Grubby

jasonpsage at jegas.com jasonpsage at jegas.com
Wed Jan 11 03:20:57 PST 2012


First of all, let me say that from everything I've read, Grub2 in
particular is the best boot loader out there, but with its
sophistication comes larger size and slightly more complicated
configuration (for me anyways.) And I've read that there have been
LILO/BRUB "flame Wars" in here - so PLEASE, this post isn't about that.
It's more about I don't know grub well enough and the book helps
sometimes.. I'll explain.

When I am using Slackware as my Host, it has Lilo. When I finish making
my LFS 7.0 OS on my /mnt/lfs partition, all I have to do to guarantee a
boot is:

1: Copy the /mnt/lfs/boot/vmlinuz-3.1-lfs-7.0 kernel file to the host
/boot/

2: edit /etc/lilo.conf and copy the last entry in the file and paste it,
change the label, the name of the kernel file and the drive where where
my LFS is located.

EXAMPLE: At end of lilo config file I see something like (comments added
for clarity)

#----------BEGIN
image=/boot/vmlinuz
root=/dev/sda2
label=Linux
read-only
#----------END

I copy-n-paste this and change the values for my LFS:

#----------BEGIN
image=/boot/vmlinuz-3.1-lfs-7.0
root=/dev/sda3
label=LFS
read-only
#----------END

Then I REBOOT - and I have the Slackware/Lilo Menu Screen, I select LFS
and it boots everytime.
Now, if your host has LILO, you might find this is pretty slick. You
MUST remember that if you make a new kernel you need to copy it to your
host's /boot/ folder before rebooting or things might not act like you
expect.

-----------Moving On

Barry mentioned that LILO has some issues that can be problematic, and I
don't doubt it for a second. I do however have trouble with GRUB. The
Book tells us some steps.. but I get differing results everytime I try
GRUB and in all cases I'm not able to run the HOST again. 

1: I am under the impression we are to install grub on the host machine
because it isn't clear in the book, further trying to install grub while
chrooted into the LFS system hasn't worked for me yet. Compiling errors
if memory serves me correctly.

2: All attempts to configure the grub menu to launch the HOST fail for
me. (note I always get one shot at this, A rescue disk would help here
surely)

Usually when grub seems like its going to work, I get a menu.. and I
think only a couple times have I personally had luck making it actually
boot. I often have to edit the menu option here and tweak it to work, it
seems so mangle the linux <xxxxxxx> line on me and I have to put it back
together - then I can boot.

Usually I get a grub rescue prompt, and I'm sorry but I've googled the
heck out of that, read all sorts of documentation... that thing is as
useless as [insert some funny remark here].

The bummer for me is I like the way Grub allows you set timing, splash
screens, fire off windows partitions and much more. Lilo does to but has
less features I suppose. 

Either Way, I have no idea yet how I could make a installable ISO just
yet that would boot, start a setup program to gather information, and
then install grub or lilo for that matter on a target machine without
messing it up. This is something I surely what to be able to do.

So this message is not so much a whine, or an ask for help as it is my
current place in this stormy ocean at this point. I've made tons of
progress, I'm hoping my Lilo Trick for folks with Lilo based hosts is
somewhat useful... but I, Like Barry and the Book recommend, would love
to use Grub without feeling sorta fearful I'm going trash the machine
everytime I try.

I know it's likely my lack of knowledge in this Grubby Area, however I
still felt like sharing the bits that have worked flawless for me as
well.

--Jason






More information about the lfs-support mailing list