[lfs-support] Problem on compiling and installing Binutils-2.21.1a

Ken Moffat zarniwhoop at ntlworld.com
Thu Jan 12 09:39:08 PST 2012


On Thu, Jan 12, 2012 at 09:15:39AM -0800, Qrux wrote:
> 
> > It isn't acceptable.  I've never seen anything like this.  The
> > report of 'Error 1' without an actual error message makes me wonder
> > if you caught stdout in a file but didn't catch stderr ?
> 
> No--this was straight cut-and-paste from console output.  But, I'm running with "-j 4", so maybe output is garbled...
> 
 Yes, that will definitely mix the output from different jobs.

> > ...Did you fail to install texinfo in chapter 5 ?  A quick test for
> > that is to try running 'info' or 'info libc'.
> 
> Ken, thanks for that idea; it was prescient.  Texinfo opened an interesting can of worms...
> 
> I'd been writing a wrapper script which untars each package and does some boilerplate with setup and clean-up.  I was using this in my script:
> 
> 	tar mxf <package>
> 
> It turns out, this blows up the texinfo 'make install'.  The compile works.  But the install fails when using 'm' with tar.  For the curious, I wanted to avoid "extracting file modified time" (otherwise known as --touch), because I was experimenting with timestamp-based "package management".  When I compiled by hand, I was just auto-piloting the "normal" invocation:
> 
> 	tar xf <package>
> 
> which worked perfectly.  I'm not sure what the root cause of the issue with the 'm' switch is...and how it would mess up an install in the way it did.
> 
 There are all manner of oddities in different packages' build
systems.  At one time, I tried touching everything that looked like
it might be a header, so that (if installed as-shipped) it would be
found when I searched for everything newer than when I started the build.

In the end, far too many packages were screwed up by that
(generally, all sorts of weird messages because they are trying to
reconfigure but need files that weren't shipped). so I ripped out
that part, along with the many workarounds for different packages.
So, back to not always knowing where a header came from.

 Nowadays, I only touch .pm and .py files, plus .man and .{1..8} so I
can still not always tell where a header came from.  Even this is
turned off for grub because that breaks.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-support mailing list