[lfs-support] Problems with GCC Pass 1 in Chapter 5

Mario Meier beanme at gmx.at
Tue Jan 24 10:36:54 PST 2012


!! I am not english native speaker. I am from Austria and maybe I will post sentences that are grammatically wrong. Please ask me if you do not understand me.

Dear Support,

I have a big problem. I already tried to build LFS multiple times.
My current try is from a VirtualBox VM with a Win7 host and an openSUSE guest system.

I put the source tarballs to a directory on the host system (accessable as shared folder at /mnt/host), but I use the LINUX tar to extract the archives. I know that using Windows applications may cause errors.

I have extracted GCC to /mnt/lfs/sources (I will call it /sources in the rest of the mail) and have set the $src variable to /mnt/host.

I always used this command to extract an archive:

tar -xvaf <package>*.tar*

That should allow me to leave out the version number and the compression file extension. The -a flag means that TAR automatically detects the compression method.

In the german support channel, they told me to leave out -a. I did so and also left out the stars and wrote the full path.

I had tested if that worked. It now says, "libmprf not found or uses  different ABI"

Could you help me please?

Thanks in advance,
*Bean*Me
-- 
"Feel free" - 10 GB Mailbox, 100 FreeSMS/Monat ...
Jetzt GMX TopMail testen: http://www.gmx.net/de/go/topmail



More information about the lfs-support mailing list