[lfs-support] Problems with GCC Pass 1 in Chapter 5

Matijn Woudt tijnema at gmail.com
Tue Jan 24 11:21:30 PST 2012


On Tue, Jan 24, 2012 at 8:17 PM, Mario Meier <beanme at gmx.at> wrote:
>
> Bruce Dubbs wrote:
>> Mario Meier wrote:
>> > !! I am not english native speaker. I am from Austria and maybe I
>> > will post sentences that are grammatically wrong. Please ask me if
>> > you do not understand me.
>>
>> Sometimes non-native speakers know more about our language than
>> native-speakers.  :)
>>
>> > I have a big problem. I already tried to build LFS multiple times. My
>> > current try is from a VirtualBox VM with a Win7 host and an openSUSE
>> > guest system.
>> >
>> > I put the source tarballs to a directory on the host system
>> > (accessable as shared folder at /mnt/host), but I use the LINUX tar
>> > to extract the archives. I know that using Windows applications may
>> > cause errors.
>> >
>> > I have extracted GCC to /mnt/lfs/sources (I will call it /sources in
>> > the rest of the mail) and have set the $src variable to /mnt/host.
>> >
>> > I always used this command to extract an archive:
>> >
>> > tar -xvaf <package>*.tar*
>> >
>> > That should allow me to leave out the version number and the
>> > compression file extension. The -a flag means that TAR automatically
>> > detects the compression method.
>>
>> > In the german support channel, they told me to leave out -a. I did so
>> > and also left out the stars and wrote the full path.
>>
>> The -a is not necessary.  I don't really care to watch the output of tar
>> any more, so I just use 'tar -xf $DIR/$PROGRAM.tar.?z*' in my scripts.
>> That gets .tar.gz, .tar.bz2, and .tar.xz.  It misses the occasional .tgz.
>>
>> > I had tested if that worked. It now says, "libmprf not found or uses
>> > different ABI"
>> >
>> > Could you help me please?
>>
>> I'm not sure what your question is.  You have openSUSE and it doesn't
>> extract the tarfiles?  What version of tar do you have?  'tar --version'.
>>
>
> My question is that it does not find MPFR!
> I am sorry, I did not read through the message before sending it.
> What my question is: Why does the GCC compilation brake?
> I am in 'make' process and it says it does not find libmpfr!
>
> My TAR Version:
>
> tar (GNU tar) 1.26
> Copyright © 2011 Free Software Foundation, Inc.
> (...)
>
> I left out the license part, because it is in german and (as I see) not relevant.
>
> I will go to vacation next week, but will be happy about an answer in my letterbox when I get back.
>
> Thanks in advance,
> *Bean*Me

Well, if make breaks, you should send your output from make where the
error occurs, and a few lines above of that.

Matijn



More information about the lfs-support mailing list