[lfs-support] Problem compiling GCC-4.7.1, Chapter 6.17, LFS 7.2

Bruce Dubbs bruce.dubbs at gmail.com
Thu Nov 8 12:27:21 PST 2012

Ralf Bauerfeind wrote:
> Hi there!
> I tried once again to get me a LFS-system.
> Intel i3, 8GB RAM, SSD 60GB + HD 2TB
> So 64 bit comes natural.
> I tried several approaches to compile gcc regarding to chapter 6.17,
> first with user package management... then as root, too.
> I fear there might be some problems with the compiled-as-user programs
> prior to gcc which leaves gcc in a state that it can't be compiled, but
> I hope it's not the case and I'm just overlooking something.
> Compiling as root, 'configure' and 'make' both run fine (similar when
> compiling as user), but after the 'ulimit' command the 'make -k check'
> gets me errors I also get when compiling gcc as user.

That's one error in libmudflap and it's documented in the book.

> A 'make install' afterwards ends into a similar error message with
> virtually no files installed.

What error?

   -- Bruce

More information about the lfs-support mailing list