[lfs-support] Installing Binutils and GCC after adjusting toolchain

Kaleb van Ingen Schenau k.ingen.schenau at gmail.com
Wed Nov 14 00:01:42 PST 2012


I'm having a bit of a problem which is stopping me from continueing with
LFS, after chapter 6.10 "Adjusting the Toolchain" i run the sanity check
and all results come out as they are supposed to be according to the book.

But after i install Binutils MPFR, MPC, GMP, ZLIB, FILE and Gcc (not in
that order) the results of the test discribed in the install/compile
section of GCC dont come out as they are supposed to be when i run:
#echo 'main(){}' > dummy.c
#cc dummy.c -v -Wl,--verbose &> dummy.log
#readelf -l a.out | grep ': /lib'

i get : [Requesting program interpreter: /lib/ld-linux.so.2] which is
when i then run :
#grep -o '/usr/lib.*/crt[1in].*succeeded' dummy.log
it gives me:
/usr/lib/crt1.o succeeded
/usr/lib/crti.o succeeded
/usr/lib/crtn.o succeeded

instead of the intended:
/usr/lib/gcc/i686-pc-linux-gnu/4.7.1/../../../crt1.o succeeded
/usr/lib/gcc/i686-pc-linux-gnu/4.7.1/../../../crti.o succeeded
/usr/lib/gcc/i686-pc-linux-gnu/4.7.1/../../../crtn.o succeeded

Then when i run :
#grep -B4 '^ /usr/include' dummy.log

it states:
Ignoring nonexistent directory
Ignoring duplicate directory "/tools/include"
#include "..." search starts here:
#include <...> search starts here:

Then when i run:
#grep 'SEARCH.*/usr/lib' dummy.log |sed 's|; |\n|g'

which is also not correct

#grep "/lib.*/libc.so.6 " dummy.log
#grep found dummy.log
DO come up with the correct output

This is the link to dummy.log:

Hope this helps and someone can shed some light on what part im messing up
on between 6.10 and 6.17
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20121114/0d037027/attachment.html>

More information about the lfs-support mailing list