[lfs-support] Kernel panic lfs-7.2

spiky martynvidler at aol.com
Thu Oct 25 15:09:32 PDT 2012

On 25/10/12 22:50, Ken Moffat wrote:
> On Thu, Oct 25, 2012 at 10:03:46PM +0100, spiky wrote:
>> Hi
>> Ok I,m having real trouble booting my lfs system. Long storey with lfs
>> 7.2 wont boot, I have now dd a working lfs-7.0 system, from another
>> laptop which I have done before. on to this laptop replacing 7.2.
>> I adjusted fstab file as needed for new partitions.
>> I have tried booting from grub prompt (host grub)
>> set root=(hd0,3)
>> linux /boot/vmlinuz-3.3-rc1-lfs-7.0
>> boot
>> I get a kernel panic
>>    "VFS unable to mount root fs via NFS trying floppy
>> VFS cannot open root device "(null)" or unknown-block(2,0)
>> please append a correct "root=" boot option here are availble partitions"
>> then it lists the sda partitions.
>> I got the same panic with the lfs 7.2 install, I have rebuilt the kernel
>> many times different configurations.
>>     I have built lfs since 6.7 and always got them to boot, this is the
>> 1st time I have built on this laptop, Nothing special about this laptop.
>> I rebuilt the kernel
>> Would really like to get this fixed Thks
>   I think the root of your problem is that you have no previous good
> .config for _this_ laptop.  As we always say, both the filesystems
> and device drivers that are required to boot need to be built in to
> the kernel.
>   But something about your report is odd - you say it lists the sda
> partitions (and I assume that is the correct drive), and I also
> assume you aren't using a different filesystem for '/' on this
> machine.  Did you perhaps specify root=/dev/hdXN instead of
> /dev/sdaN in grub.cfg ?
> ĸen
I rebuilt the kernel after moving to new laptop. Root is on sda3 ext4 
only 1 harddrive,
sda1 will be boot "NOT used at moment"
sda2 extended partition
I have not run grub-install No grub.cfg file yet. Hence why I,m using 
grub prompt "which I should be able to boot from"
Also the tab complition at grub prompt shows the correct paths to vmlinuz.
I will run grub-install tomorrow But when i done all this on the 
orginall lfs 7.2 I still ended up with the same panic.

FYI I have set ext4 in kernel config and the mount dev at boot which is 
also in fstab
Booting from grub prompt

File systems should be configured in kernel ok. Drivers I have tried 
various drivers for radeon graphics card.

More information about the lfs-support mailing list